Welches Java ist jetzt Mindestanforderung?

Infos, Fragen, Ideen und alles rund um P2Tools
Antworten
thowe
Beiträge: 65
Registriert: 09 Mai 2023, 09:10

Welches Java ist jetzt Mindestanforderung?

Beitrag von thowe »

Die Anforderungen ans installierte Java haben sich geändert, oder?

Ich hab ein Java 11+ installiert (SUSE Tumbleweed standardinstallation), und damit will MTP nicht starten.

Code: Alles auswählen

localhost% which java
/usr/bin/java
localhost% java --version
openjdk 11.0.21 2023-10-17
OpenJDK Runtime Environment (build 11.0.21+0-suse-1.1-x8664)
OpenJDK 64-Bit Server VM (build 11.0.21+0-suse-1.1-x8664, mixed mode)
localhost% /home/icke/Applications/MTPlayer/MTPlayer__Linux.sh
dann Java vom System
Error: LinkageError occurred while loading main class de.p2tools.mtplayer.Main
java.lang.UnsupportedClassVersionError: de/p2tools/mtplayer/Main has been compiled by a more recent version of the Java Runtime (class file version 61.0), this version of the Java Runtime only recognizes class file versions up to 55.0
Laut den Docs müsste Java 11 aber reichen:

> README.txt
> * Für Linux-Benutzer wird OpenJDK empfohlen (oder das Programmpaket das Java bereits enthält und so ohne Java-Installation auskommt).

> Linux/Info.txt
> * Java ist nicht oder nicht in der richtigen Version installiert (Java11, Java11+). Zum Java-Download: https://jdk.java.net/


Hab Java 21 dazu installiert, damit funktioniert die v16 B1. :-)
XaverW
Site Admin
Beiträge: 135
Registriert: 29 Apr 2023, 14:34

Re: Welches Java ist jetzt Mindestanforderung?

Beitrag von XaverW »

java 17 ist jetzt die Mindestvoraussetzung. Wo steht noch 11 in den Docs?
Das habe ich dann übersehen zu ändern.
w [punkt] xaver [at] googlemail [punkt] com
XaverW
Site Admin
Beiträge: 135
Registriert: 29 Apr 2023, 14:34

Re: Welches Java ist jetzt Mindestanforderung?

Beitrag von XaverW »

habs gefunden, sind die infos in den zip-Dateien. Habs ausgebessert, bei Downloads ab jetzt stimmts wieder.
w [punkt] xaver [at] googlemail [punkt] com
Benutzeravatar
linuxopa
Beiträge: 98
Registriert: 06 Mai 2023, 18:51

Re: Welches Java ist jetzt Mindestanforderung?

Beitrag von linuxopa »

:beer:
XaverW hat geschrieben: 25 Dez 2023, 19:13 habs gefunden, sind die infos in den zip-Dateien. Habs ausgebessert, bei Downloads ab jetzt stimmts wieder.
Antworten